Author Topic: BW1 on Windows 7/8/10  (Read 64306 times)

0 Members and 1 Guest are viewing this topic.

Offline wefwewfefwefweww

  • July 2017
  • 7 Posts
  • Reputation Power: 1
  • wefwewfefwefweww has no influence.
Re: BW1 on Windows 7/8/10
« Reply #105 on: Jul 14, 2017, 08:39 pm »
You shouldn't really run the game as admin. Lemme know what GPU you have, are you drivers installed? Any crash logs etc (check windows event viewer)

GTX 1080, Version of driver is 384.76

From windows event log:

Code: [Select]
System

  - Provider

   [ Name]  Application Error
 
  - EventID 1000

   [ Qualifiers]  0
 
   Level 2
 
   Task 100
 
   Keywords 0x80000000000000
 
  - TimeCreated

   [ SystemTime]  2017-07-14T19:36:23.296701300Z
 
   EventRecordID 1142076
 
   Channel Application
 
   Computer DESKTOP-VB72PLV
 
   Security
 

Offline wefwewfefwefweww

  • July 2017
  • 7 Posts
  • Reputation Power: 1
  • wefwewfefwefweww has no influence.
Re: BW1 on Windows 7/8/10
« Reply #106 on: Jul 15, 2017, 05:30 pm »
GTX 1080, Version of driver is 384.76

From windows event log:

Code: [Select]
System

  - Provider

   [ Name]  Application Error
 
  - EventID 1000

   [ Qualifiers]  0
 
   Level 2
 
   Task 100
 
   Keywords 0x80000000000000
 
  - TimeCreated

   [ SystemTime]  2017-07-14T19:36:23.296701300Z
 
   EventRecordID 1142076
 
   Channel Application
 
   Computer DESKTOP-VB72PLV
 
   Security
 


?????

Offline BigBuddha

  • July 2017
  • 2 Posts
  • Reputation Power: 1
  • BigBuddha has no influence.
Re: BW1 on Windows 7/8/10
« Reply #107 on: Jul 16, 2017, 05:10 pm »
Hi everyone! Had to register only to make this one post :D. To those that are having problem with the "lh has stopped working" and problems with patches when installing, what you need to do after you've cleaned your register and are going to try a re-install, install it into C:\ and make a folder WITHOUT SPACES!

In the installer program, remove the "&" symbol and all spaces. Example: C:\Games\BlackWhite  <-- this is how i did it and the "lh has stopped working" went away and all patches installed without a problem.

Thought i should post this since i myself had quite a problem until i noticed this :D Good luck!
Remember: NO spaces or funny symbols! ( " & " )

Remember to also thoroughly make sure you have removed all Registry values for BW1 before you attemt an re-install. I used Registrar Register Manager and did a Search for "Lionhead" and all relevant entries will show up for you to delete.

(http://www.resplendence.com/registrar) <- Software i used to clean register, don't know if posting this link is ok but i'll just wing it xD. Otherwise google "Registrar Registry Manager".

They have Home Edition which is free and Commercial/Professional for businesses with more advanced options that you pay for. To do this though all you need is the Home Edition. 

MAKE SURE THEY ARE FOR BW1 FIRST THOUGH, if you have BW2 installed that will show up as well.
If you have BW2 installed you can do a search for "Lionhead Studios Ltd" instead, that will give you all entries related to BW1 only.
« Last Edit: Jul 16, 2017, 07:32 pm by BigBuddha »

Offline Handsome Matt

  • August 2005
  • 252 Posts
  • Reputation Power: 21
  • Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!



    • My Portfolio
Re: BW1 on Windows 7/8/10
« Reply #108 on: Jul 16, 2017, 08:37 pm »
You can solve those issues with the install by just running the installer as admin.

Offline wefwewfefwefweww

  • July 2017
  • 7 Posts
  • Reputation Power: 1
  • wefwewfefwefweww has no influence.
Re: BW1 on Windows 7/8/10
« Reply #109 on: Jul 16, 2017, 10:11 pm »
You can solve those issues with the install by just running the installer as admin.

Tried installing as admin, nothing.

Also cleaned the registery with everything related to bw and installs using the software BigBuddha linked.
And no wierd letters in the installpath. Still does not work.

Offline Handsome Matt

  • August 2005
  • 252 Posts
  • Reputation Power: 21
  • Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!



    • My Portfolio
Re: BW1 on Windows 7/8/10
« Reply #110 on: Jul 16, 2017, 10:25 pm »
Tried installing as admin, nothing.

Also cleaned the registery with everything related to bw and installs using the software BigBuddha linked.
And no wierd letters in the installpath. Still does not work.

Your issue is entirely different, the event log you posted didn't really reveal anything. I can't really help you out becasue I don't know what the issue is, you need to run the game through a debugger such as WinDbg and post the logs here, maybe it reveals the error.

Actually https://technet.microsoft.com/en-us/sysinternals/bb896647.aspx DebugViewer should do fine.
« Last Edit: Jul 16, 2017, 11:17 pm by Handsome Matt »

Offline wefwewfefwefweww

  • July 2017
  • 7 Posts
  • Reputation Power: 1
  • wefwewfefwefweww has no influence.
Re: BW1 on Windows 7/8/10
« Reply #111 on: Jul 17, 2017, 03:07 pm »
Your issue is entirely different, the event log you posted didn't really reveal anything. I can't really help you out becasue I don't know what the issue is, you need to run the game through a debugger such as WinDbg and post the logs here, maybe it reveals the error.

Actually https://technet.microsoft.com/en-us/sysinternals/bb896647.aspx DebugViewer should do fine.

How do I use it to capture runblack.exe?

Offline wefwewfefwefweww

  • July 2017
  • 7 Posts
  • Reputation Power: 1
  • wefwewfefwefweww has no influence.
Re: BW1 on Windows 7/8/10
« Reply #112 on: Jul 17, 2017, 03:10 pm »
This appeared at the moment of the crash:

[8920] *** IFC Error!  "COM/DirectInput Error" [HRESULT = 0x80040154 (CODE = 340)]

Offline Handsome Matt

  • August 2005
  • 252 Posts
  • Reputation Power: 21
  • Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!



    • My Portfolio
Re: BW1 on Windows 7/8/10
« Reply #113 on: Jul 17, 2017, 04:02 pm »
Pasting the whole log I should be able to see what's wrong better, however this looks like a DirectInput issue. Do you have any gamepads plugged in? Or any other weird USB peripherals?

Offline axpasq

  • July 2017
  • 1 Posts
  • Reputation Power: 1
  • axpasq has no influence.
Re: BW1 on Windows 7/8/10
« Reply #114 on: Jul 17, 2017, 06:18 pm »
I need help I downloaded this game on Abandonware and it wants to run black and white as a test and I cant find the black and white file to install patches only a runblack.exe file can anyone help me?

Offline wefwewfefwefweww

  • July 2017
  • 7 Posts
  • Reputation Power: 1
  • wefwewfefwefweww has no influence.
Re: BW1 on Windows 7/8/10
« Reply #115 on: Jul 17, 2017, 07:44 pm »
Pasting the whole log I should be able to see what's wrong better, however this looks like a DirectInput issue. Do you have any gamepads plugged in? Or any other weird USB peripherals?

Code: [Select]
[8052] onecoreuap\shell\onecoretdlhelpers\tiledatalayeritemwrappers.cpp(1183)\appresolver.dll!00007FFAA744283D: (caller: 00007FFAA7425F39) ReturnHr(847) tid(3314) 80070057 Felaktig parameter.
[8052] onecore\base\appmodel\resourcepolicy\gameconfigstore\client\gameconfigstoreclient.cpp(104)\ResourcePolicyClient.dll!00007FFAC812BA6C: (caller: 00007FFAA56F3FB6) LogHr(113) tid(1cc8) 80070490 Det gick inte att hitta elementet.
[8052] avcore\npsm\localprovider\baseprovider\lib\baseprovider.cpp(604)\NPSMDesktopProvider.dll!00007FFA7E1A39A4: (caller: 00007FFA7E1A4113) ReturnHr(110) tid(ee4) 80070490 Det gick inte att hitta elementet.
[8052] onecoreuap\shell\lib\bindctx.cpp(128)\explorerframe.dll!00007FFAA652378F: (caller: 00007FFAA64FAA7F) ReturnHr(1042) tid(f18) 80070057 Felaktig parameter.
[8052] onecoreuap\shell\lib\bindctx.cpp(128)\explorerframe.dll!00007FFAA652378F: (caller: 00007FFAA64FAA7F) ReturnHr(1043) tid(808) 80070057 Felaktig parameter.
[8052] onecoreuap\shell\lib\bindctx.cpp(128)\explorerframe.dll!00007FFAA652378F: (caller: 00007FFAA64FAA7F) ReturnHr(1044) tid(2a68) 80070057 Felaktig parameter.
[8052] onecoreuap\shell\lib\bindctx.cpp(128)\explorerframe.dll!00007FFAA652378F: (caller: 00007FFAA64FAA7F) ReturnHr(1045) tid(2bd0) 80070057 Felaktig parameter.
[8052] onecoreuap\shell\lib\bindctx.cpp(128)\explorerframe.dll!00007FFAA652378F: (caller: 00007FFAA64FAA7F) ReturnHr(1046) tid(23ec) 80070057 Felaktig parameter.
[8052] onecoreuap\shell\lib\bindctx.cpp(128)\explorerframe.dll!00007FFAA652378F: (caller: 00007FFAA64FAA7F) ReturnHr(1047) tid(8b8) 80070057 Felaktig parameter.
[8052] onecoreuap\shell\lib\bindctx.cpp(128)\explorerframe.dll!00007FFAA652378F: (caller: 00007FFAA64FAA7F) ReturnHr(1048) tid(16b8) 80070057 Felaktig parameter.
[8052] onecore\base\appmodel\resourcepolicy\gameconfigstore\client\gameconfigstoreclient.cpp(104)\ResourcePolicyClient.dll!00007FFAC812BA6C: (caller: 00007FFAA56F3FB6) LogHr(114) tid(32d0) 80070490 Det gick inte att hitta elementet.
[8052] avcore\npsm\localprovider\baseprovider\lib\baseprovider.cpp(604)\NPSMDesktopProvider.dll!00007FFA7E1A39A4: (caller: 00007FFA7E1A4113) ReturnHr(111) tid(ee4) 80070490 Det gick inte att hitta elementet.
[10488]    /------------------------------------------------------------
[10488]    | DD Driver : Primär bildskärmsdrivrutin
[10488]    |             display
[10488]    | this is the primary display.
[10488]    | Driver Version nvldumd.dll
[10488]    | 3D hardware capabilities.
[10488]    \------------------------------------------------------------
[10488] NOT A KYRO
[10488] NOT A KYRO
[10488] Display selected: NVIDIA GeForce GTX 1080.
[10488] <<<<< LH3DRender: Finish without start. >>>>>
[10488] #OPEN#
[10488] -14177536 TEXTURE AVAILABLE
[10488] Already Open!
[10488] #OPEN D3D#
[10488] ZBUFFER: 16
[10488] ZBUFFER: 32
[10488] ZBUFFER: 32
[10488] ZBUFFER: 24
[10488] ZBUFFER 16 bits
[10488] We choose  : (16 bits) Zbuffer                00000000 00000000 0000FFFF 00000000
[10488] Support AGP.
[10488] Doesn't support hardware T'n'L / tnl disabled.
[10488] check mode 1:
[10488] (caps say it's supported)
[10488] state block for mode 1 is nvidia method!
[10488] check mode 2:
[10488] (caps say it's supported)
[10488] state block for mode 2 is nvidia method!
[10488] check mode 3:
[10488] (caps say it's supported)
[10488] state block for mode 3 is nvidia method!
[10488] check modulate:
[10488] (caps say it's supported)
[10488] state block for mode 4 is nvidia method!
[10488] check modulate 2x:
[10488] (caps say it's supported)
[10488] state block for mode 5 is nvidia method!
[10488] check mode 6:
[10488] (caps say it's supported)
[10488] state block for mode 6 is nvidia method!
[10488] check additive:
[10488] (caps say it's supported)
[10488] state block for mode 7 is nvidia method!
[10488] >> lh3dvram open
[10488] FindTexture: (16 bits)       RGB      00000000 00007C00 000003E0 0000001F
[10488] FindTexture: (16 bits) ALPHA RGB      00008000 00007C00 000003E0 0000001F
[10488] FindTexture: (16 bits) ALPHA RGB      0000F000 00000F00 000000F0 0000000F
[10488] FindTexture: (16 bits)       RGB      00000000 0000F800 000007E0 0000001F
[10488] FindTexture: (32 bits)       RGB      00000000 00FF0000 0000FF00 000000FF
[10488] FindTexture: (32 bits) ALPHA RGB      FF000000 00FF0000 0000FF00 000000FF
[10488] FindTexture: (16 bits)                00000000 000000FF 0000FF00 00000000
[10488] FindTexture: (32 bits)                00000000 000000FF 0000FF00 00FF0000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 8 bits)                00000000 000000FF 00000000 00000000
[10488] FindTexture: ( 8 bits) ALPHA          00000000 00000000 00000000 00000000
[10488] FindTexture: (16 bits) ALPHA          0000FF00 000000FF 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] FindTexture: ( 0 bits)                00000000 00000000 00000000 00000000
[10488] We choose  : (16 bits) ALPHA RGB      0000F000 00000F00 000000F0 0000000F
[10488] We choose  : (16 bits)       RGB      00000000 00007C00 000003E0 0000001F
[10488] We choose  : (32 bits) ALPHA RGB      FF000000 00FF0000 0000FF00 000000FF
[10488]
[10488] After VRAM: 2064
[10488] After AGP: 2064
[10488] using z buffer for sun before check
[10488]
[10488] JC: find 3 555
[10488] try alloc 5 555s.
[10488] Release 5 555s
[10488]
[10488] JC: find 3 555
[10488] try alloc 5 555s.
[10488] Release 5 555s
[10488] InitialiseAudio
[10488]
[10488] JC: find 3 555
[10488] try alloc 5 555s.
[10488] Release 5 555s
[10488]
[10488] JC: find 3 555
[10488] try alloc 5 555s.
[10488] InitOneTimeOnly
[10488] LoadTextScript
[10488] LHNetUseProfile
[10488] ReinitLoadingScreen
[10488] EditorPhysics::Load
[10488] GSpookyVoices
[10488] GConfirmation
[10488] StartupGameInfo
[10488] load_variables
[10488] SetupStatics
[10488] *** IFC Error!  "COM/DirectInput Error" [HRESULT = 0x80040154 (CODE = 340)]
[10488] LHCheckForInternetConnection
[10488] GetNumberOfProfiles
[8052] avcore\npsm\localprovider\baseprovider\lib\baseprovider.cpp(604)\NPSMDesktopProvider.dll!00007FFA7E1A39A4: (caller: 00007FFA7E1A4113) ReturnHr(112) tid(ee4) 80070490 Det gick inte att hitta elementet.
[8052] avcore\npsm\localprovider\baseprovider\lib\baseprovider.cpp(604)\NPSMDesktopProvider.dll!00007FFA7E1A39A4: (caller: 00007FFA7E1A4113) ReturnHr(113) tid(ee4) 80070490 Det gick inte att hitta elementet.


(Running with admin rights, running without it starts nothing and nothing happens at all. The IFC error thing appears when you first are able to see a version number).

I had the same toughts about joypads etc. So I disconnected them all including my wireless keyboard. And same error.

EDIT: just a tought, but could it be because I have two monitors?

Offline Handsome Matt

  • August 2005
  • 252 Posts
  • Reputation Power: 21
  • Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!



    • My Portfolio
Re: BW1 on Windows 7/8/10
« Reply #116 on: Jul 17, 2017, 11:22 pm »
I need help I downloaded this game on Abandonware and it wants to run black and white as a test and I cant find the black and white file to install patches only a runblack.exe file can anyone help me?

I don't understand what you mean?

EDIT: just a tought, but could it be because I have two monitors?

hmm I don't think so I run the game on a GTX 1080 and also have 2 monitors and it runs fine. "Det gick inte att hitta elementet. " - stands for something can't be found? But yeah the "*** IFC Error!  "COM/DirectInput Error" [HRESULT = 0x80040154 (CODE = 340)]" should 100% not be there, I've tried googling it a bit and it just seems to be a really obscure issue with older games on Windows 10, I really don't know how to fix it sorry.

Offline squaz

  • July 2017
  • 1 Posts
  • Reputation Power: 1
  • squaz has no influence.
Re: BW1 on Windows 7/8/10
« Reply #117 on: Jul 20, 2017, 05:55 am »
Hello Handsome Matt,

I also have the issue where I can't run the game in a higher resolution than 1080p.

Trying to play in 1440p and the game is having none of it.

I've tried windowed mode and full screen. The mouse cursor lags when it tries to load and then promptly crashes.

Does yours just work?

If you want I can do a little demo video of it starting up and link it to this forum.

Offline Teratrain

  • July 2017
  • 3 Posts
  • Reputation Power: 1
  • Teratrain has no influence.
Re: BW1 on Windows 7/8/10
« Reply #118 on: Jul 21, 2017, 08:18 pm »
Going for a reinstall but having some real difficulty with the installers.  First install went reasonably well, managed to install the base game but things started to fall apart when I was installing the patches - started seeing this:



Tried to run through the rest of the setup but nothing else wanted to install, it's all Catastrophic Failures.  Figured I'd start from scratch, except now the base game won't uninstall due to the same goddamn error.  I nuked the install directory and flushed the registry entries... and now the base game won't install due to the same awful generic error.

Any suggestions?  From what I can tell this is something to do with InstallShield shitting the bed but I can't find any working suggestions outside of updating it (does nothing) or deleting the directory in program files\common files\installshield (also does nothing, although it looks like the game tries to recreate it when you run the installer)

Any suggestions?  Anyone know if it's worth just running the game in an XP VM?

Offline Handsome Matt

  • August 2005
  • 252 Posts
  • Reputation Power: 21
  • Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!



    • My Portfolio
Re: BW1 on Windows 7/8/10
« Reply #119 on: Jul 22, 2017, 11:53 am »
You probably need to nuke your registry and existing install files like I explain in the opening post.