Black & White Community

Black & White 2 => Technical Help => Topic started by: ItamarGronich on Jul 10, 2020, 01:56 pm

Title: Graphics issues
Post by: ItamarGronich on Jul 10, 2020, 01:56 pm
Hey guys!
My game works good except the graphics are on lowest quality.
I can't set it up to high even if I click on high it just doesn't load the graphics it seems. I've got pretty modern hardware.
I read that the fan patch is supposed to fix that.
I've installed 1.1, 1.2 and fan patch 1.4 but still locked on low.
Running white.exe as administrator.
Also tried comparability modes 95/98 me, 7, Vista etc.....

Hardware:
CPU: AMD Ryzen 5 3600x
GPU: AMD Radeon RX 5700 XT
OS: Windows 10 pro 64 bit

I followed the instructions on the pinned thread for installation.
I did however get an error during install (iso downloaded from my abandonware.com)
I continued anyway and the game still works.
Just the graphics thing.
Title: Re: Graphics issues
Post by: BardBun on Jul 12, 2020, 01:15 pm
Do you mean Black&White 1?

There is no Patch 1.4 for Black&White 2.
Title: Re: Graphics issues
Post by: ItamarGronich on Jul 12, 2020, 07:58 pm
Do you mean Black&White 1?

There is no Patch 1.4 for Black&White 2.

I mean Black & White 2.
I believe the version number of the fan patch itself for black and white 2 is 1.4
Looks at this link and see https://www.bwfiles.com/files/file.php?id=1421

It was 1.3 but was bumped to 1.4
Title: Re: Graphics issues
Post by: ItamarGronich on Jul 13, 2020, 06:36 pm
 :fixed :fixed :fixed :fixed :fixed  :fixed
I managed to fix it.
I went to graphics.config file and added my graphics card name in there and set to the highest quality.
My card is Radeon RX 5700 XT.
I tried all the combinations of the name in the file
Like:
RX5700              3  0  3
RX 5700 XT       3  0  3
RX5700 XT        3  0  3
5700 XT             3  0  3
Etc...
One of them finally hit.
 :fixed :fixed :fixed :fixed :fixed  :fixed
Title: Re: Graphics issues
Post by: 1NV1CTUS on Jul 27, 2020, 11:02 pm
I noticed that there's a black square on every lamp or torch that emits light. Any idea why this is?
Title: Re: Graphics issues
Post by: CommanderWyn on Aug 13, 2020, 08:02 pm
Hey ItamarGronich! I'm having the same problem as you, I have a Radeon RX 5700 (I didn't go with the XT version, kinda kicking myself for it haha!) For me the game is like rubbing at a double speed, the dialogue is being skipped, as it seems like the game is running faster than it should. I've tried editing my graphic files and it's not working, how did you fix these problems? I've followed every step!