Author Topic: BW1 on Windows 7/8/10  (Read 230114 times)

0 Members and 4 Guests are viewing this topic.

Offline angrygreek

  • November 2019
  • 5 Posts
  • Reputation Power: 1
  • angrygreek has no influence.
Re: BW1 on Windows 7/8/10
« Reply #225 on: Nov 26, 2019, 06:22 am »
I have a 1440p monitor. If I try to set the game to 1440p it crashes on startup.

If I try 4k it crashes on startup.

If I set it 1080p it works.

Why can't I go higher than 1080p?

Offline Handsome Matt

  • August 2005
  • 282 Posts
  • Reputation Power: 21
  • Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!Handsome Matt is awe-inspiring!



    • My Portfolio
Re: BW1 on Windows 7/8/10
« Reply #226 on: Nov 26, 2019, 01:02 pm »
I have a 1440p monitor. If I try to set the game to 1440p it crashes on startup.

If I try 4k it crashes on startup.

If I set it 1080p it works.

Why can't I go higher than 1080p?

DirectX bug, I have uploaded a fixed version now, you can download it from here: https://www.bwfiles.com/downloads/files/BWFanPatchInstaller.exe

Offline RealSmooth

  • December 2019
  • 2 Posts
  • Reputation Power: 1
  • RealSmooth has no influence.
Re: BW1 on Windows 7/8/10
« Reply #227 on: Dec 07, 2019, 10:23 pm »
Autosave and save features aren't working.
autosaves at the beginning of the lands (the first creature stone on land one, and the temple being built on land 2) and then sometime into the game will say "LH has stopped working" forcing it to close and then when I reload the game I'm taken straight back to the start of the level
any help would be wicked

Offline RealSmooth

  • December 2019
  • 2 Posts
  • Reputation Power: 1
  • RealSmooth has no influence.
Re: BW1 on Windows 7/8/10
« Reply #228 on: Dec 08, 2019, 08:35 pm »
Autosave and save features aren't working.
autosaves at the beginning of the lands (the first creature stone on land one, and the temple being built on land 2) and then sometime into the game will say "LH has stopped working" forcing it to close and then when I reload the game I'm taken straight back to the start of the level
any help would be wicked

now it's just taken me right back to the start to the cutscene of the kid drowning :help

Offline Lawrian

  • January 2020
  • 1 Posts
  • Reputation Power: 1
  • Lawrian has no influence.
Re: BW1 on Windows 7/8/10
« Reply #229 on: Jan 13, 2020, 08:22 pm »
Hi! I'm super sorry if someone already asked this! I may have missed it in the thread. I've been trying to follow this post exactly but I've been runing into some problems (Windows 10). I managed to delete the registry keys, install the game, the addons, and the first patch wthout issue. However when I get to the second patch it all goes wrong.

I click run as admin but it comes up with an error essage saying this:

"An installation support file 'C:\Program Files (x86)\Common Files\InstallShield\engine\6\Intel 32\ctor.dll'
could not be installed.
Access is denied"


I dont really know how to give it more access than running it as admin? I decided to see if I could skip patch 2 and go straight to the fan patch but that didn't work correctly either. I clicked run as admin on the fan patch and it has an error message saying:

"Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item"

Again I dont know how to give it any more permission than i'm already giving it so I'm at a loss. I'm using the only user account on this laptop and am just running the ISO and patches from a folder on the desktop. I don't know what I'm doing wrong :( Please help if you can, I've been wanting to replay this game for years but I can never figure out how to make it work again. Thank you so much for your time!

(also so sorry I didnt add images. I'm stupid and couldnt figure out how)

Offline browncoat1984

  • January 2020
  • 1 Posts
  • Reputation Power: 1
  • browncoat1984 has no influence.
Re: BW1 on Windows 7/8/10
« Reply #230 on: Jan 28, 2020, 06:25 pm »
So I am trying to run B & W on windows 10, I got B&W 1 working but I'm trying to install Creature Isle and when I try to launch the .exe it acts like it launches then gives a black screen and back to desktop, is there something special I need to do to get the expansion to work?

Offline BardBun

  • February 2020
  • 7 Posts
  • Reputation Power: 1
  • BardBun has no influence.
Re: BW1 on Windows 7/8/10
« Reply #231 on: Feb 29, 2020, 05:57 pm »
DirectX bug, I have uploaded a fixed version now, you can download it from here: https://www.bwfiles.com/downloads/files/BWFanPatchInstaller.exe
Can you update it here too: https://www.bwfiles.com/files/file.php?id=1418 ?

Because that one is still the old 1.41 with the resolution bug that crashes the game and many people won't search through the forums to find a pretty hidden but amazing 1.42 version.
Almost like trying to find all 9 Sheep without looking up their locations.

Offline blackf0x_pt

  • March 2020
  • 1 Posts
  • Reputation Power: 1
  • blackf0x_pt has no influence.
Re: BW1 on Windows 7/8/10
« Reply #232 on: Mar 07, 2020, 04:51 pm »
Hi guys, im here because i have the same desire of you, of playing this in our modern machines.

So i tried to follow up the guidelines of First Page, but i faced with several problems.

  • I havent the game, so i have to downloaded by torrent. I installed, all seems good.
  • I cant install the 1.1 and 1.2 patch, its says " an installation support file could not be installed catastrophic failure "
  • so i skip that, i tried to install the 1.4 fan patch, all seems work, i setup the game, and run it, but it crashs on loading screen, just after the intro. Just shutdown the game.

Anyone know, if its because a downloaded version? Or its because i dont have the 1.1 and 1.2 official patches installed?

Thank you


edit: I REINSTALLED, AND SEEMS WORKING NOW!!!
« Last Edit: Mar 07, 2020, 05:25 pm by blackf0x_pt »

Offline Doomsiren

  • March 2020
  • 1 Posts
  • Reputation Power: 1
  • Doomsiren has no influence.
Re: BW1 on Windows 7/8/10
« Reply #233 on: Mar 08, 2020, 02:11 pm »
First off thanks for the patch. The game is up and running!

I'm missing a custom option in the setup.exe though. Does the maximum detail option in the fan patch cover the additional options provided by the game's original setup.exe? I need to be pretty close to the ground with the camera to see animal models and such appear.

Offline BardBun

  • February 2020
  • 7 Posts
  • Reputation Power: 1
  • BardBun has no influence.
Re: BW1 on Windows 7/8/10
« Reply #234 on: Mar 14, 2020, 08:16 pm »
First off thanks for the patch. The game is up and running!

I'm missing a custom option in the setup.exe though. Does the maximum detail option in the fan patch cover the additional options provided by the game's original setup.exe? I need to be pretty close to the ground with the camera to see animal models and such appear.
Download the 1.42 version from this post:
https://www.bwfiles.com/forum/index.php?topic=7916.msg56218#msg56218

Also, you shouldn't change anything in any of the setups other than the resolution you want to have.
On default the patch will set everything to max and if you try and change things manually you might get the bug that sets the drawing distance short.